Incident detail

Investigating a problem with Procure synchronization

Incident Report for wescale

Monitoring

A fix has been implemented, and our team is currently monitoring the results to ensure stability.
If users are still seeing a stuck shopping cart, please perform a manual resync.
Posted Feb 02, 2026 - 11:19 UTC

Investigating

We're investigating an issue with the synchronization between wescale and Procure Server which can lead to sporadic errors for the user.
Posted Feb 02, 2026 - 10:38 UTC
This incident affects: Product Line Procurement Solutions (Procure).