Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Feb 01, 2026 - 04:00 UTC
Update
We will be undergoing scheduled maintenance during this time.
Posted Jan 26, 2026 - 10:22 UTC
Scheduled
Dear wescale Customer,
As part of our regular security maintenance, we will rotate the TLS/SSL certificates used in the wescale Production environment. This announcement is relevant only for customers whose systems connect to wescale programmatically or through integrations that rely on a custom trust store.
>>> Action Required (only if you use a custom trust store) <<< If your systems rely on manually maintained or restricted trust stores (e.g., SecureOCI, cXML connections, API integrations, ABAP client, internal proxies/gateways, or SFTP connections), please ensure the following before the certificate rotation date:
1. Ensure the Let's Encrypt Root Certificate (ISRG Root X1) is included in your trust store. - This is the recommended long-term approach and avoids outages during intermediate certificate changes. 2. If importing the root certificate is not possible: - Import the currently used Let's Encrypt intermediate certificate (E7 and E8). - Do not import leaf certificates, as they change frequently and cannot be tracked manually. 3. Verify that no proxy, gateway, or security appliance is blocking Let's Encrypt certificate chains.
>>> Certificate Locations for Reference <<< For reference, the certificates used in the chain are located here:
If you use the default trust store of your operating system, browser, Java runtime, or standard cloud environment, no action is required.
Please complete any required trust store updates before this date to ensure uninterrupted access.
If you need assistance verifying your configuration, our support team will be happy to help.
Sincerely, The wescale Security Team
Posted Jan 26, 2026 - 09:39 UTC
This scheduled maintenance affected: Product Line Platform (Authentication Management, Infrastructure Services) and Product Line Integration (API Gateway).