Incident detail

Investigating a problem with Procure synchronization

Incident Report for wescale

Resolved

The incident has been resolved.
Posted Sep 11, 2025 - 15:03 UTC

Monitoring

The fix has been implemented and we are monitoring the results.
Posted Sep 11, 2025 - 10:41 UTC

Identified

The issue has been identified and a fix is being implemented
Posted Sep 11, 2025 - 09:55 UTC

Investigating

We're investigating an issue with the synchronization between wescale and Procure Server which can lead to sporadic errors for the user.
Posted Sep 11, 2025 - 09:06 UTC
This incident affected: Product Line Procurement Solutions (Procure).